تاریخ امروز :
iOS
macOS
Xcode
iTunes
نمایش نتایج: از 1 به 1 از 1

موضوع: چرا اکنون نمیشود Siri را برای آیفون ۴ ارائه کرد ؟

  1. #1
    تاریخ عضویت
    Jul 2010
    محل سکونت
    Sanandaj
    نوشته ها
    1,567
    ورژن iOS
    8.1.2
    ورژن Mac
    10.10.2
    سپاس
    4,179
    از این کاربر 3,699 بار در 1,228 ارسال سپاس شده است.

    پیش فرض چرا اکنون نمیشود Siri را برای آیفون ۴ ارائه کرد ؟



    صحبت ها و متن زیر برگرفته از وبلاگ chpwn هست :

    همونطور که stroughtonsmith@ و من ( chpwn@ ) چند روز پیش ثابت کردیم، امکان اجرای Siri روی آیفون ۴ و آیپاد نسل چهارم وجود داره. به هر حال، همونطوری که ما الان نمیتونیم خود پورت و روش انجام اون رو منتشر کنیم، فکر کنم بهتره لااقل در مورد اینکه چرا الان نمیتونیم اینکار رو انجام بدیم بحث کنیم ؛

    برای یه پیش زمینه کم، لازمه اساس اینکه قانون copyright چطور کار میکنه رو بدونید. اپل صاحب copyright عکس ها و نرم افزارها و اطلاعات استفاده شده درون iOS هستش چون خودشون درستش کردند. به همین دلیل، میتونن تصمیم بگیرن که بقیه مردم چه کارهایی میتونن ( اجازه شو دارن ) که با این فایلها انجام بدن : کپی کردن، منتشر کردن، تطابق دادن، تغییر دادن یا هر تغییر دیگری که از کارشون محافت میکنه. بسیار ساده هستش. ولی به یه قانون خیلی مهم منتهی میشه : فقط به این دلیل که یه داده ای آزادانه در اینترنت وجود داره، به این معنی نیست که شما حق پخش مجدد اون داده ( یا حتی بخشی از اون رو ) بدون یک لیسانس معتبر دارید. در عمل این به اون معنی هستش که فقط به این دلیل که برخی فایلها آزادانه در یک دستگاه یا درون فایلهای مرتبط با اون (* ipsw ) به راحتی از صفحه وب اپل قابل دانلود هستند، به این معنی نیست که این فایل ها را بطور قانونی میتوان توسط شخصی دیگر منتشر کرد.


    در مورد محتوای Siri، یعنی فایل های اصلی و کد های که باعث شکل گیری Siri میشن را نمیتوان آزادانه منتشر کرد. این فایل ها و پلاگین هایی که با هم Siri رو ایجاد میکنن در هیچ نسخه دیگه ایی از iOS بغیر از اونی که روی آیفون 4S هستش، وجود ندارند. به همین دلیل باید این فایلها رو از درون یک آیفون 4S که در حال کار هستش یا از داخل فیرم ویر اون ( ipsw ) جدا کرد. در حالت اول شما باید یه آیفون 4S داشته باشید که بتونین فایلها رو از درونش کپی کنین که برای خیلی ها کاربردی نیست، چون اگه یه آیفون 4S داشته باشین، پس Siri رو دارین. و مشکل مورد دوم بیشتر تکنیکی هستش : فایلهای فیرم ویر بصورت کد گذاری شده منتشر میشن و ما هنوز کلید رمز برداری از این فایلها رو برای دسترسی به فایلهای Siri نداریم.


    به همین دلیل شما باید یه آیفون 4S داشته باشین که بدون نقض copyright بتونین Siri رو نصب کنین. اما باز هم این همه اش نیست : اگر همه این کار ها رو هم انجان بدید، بازهم دلایلی هست که Siri کار نخواهد کرد.


    دلایلی هست که الان نمیتونم بهتون بگم چون نیازمند یه آیفون 4S جیلبریک شده هستش که هنوز این جیلبریک در دسترس همه قرار نگرفته. به هر حال نکته مهم اینه که شما حتما به یه آیفون 4S جیلبریک شده برای دسترسی به فایلهایی که بتونین باهاشون Siri رو به کار بندازین احتیاج دارین که هنوز انجام نشده. (*و نمیدونم که چه زمانی هم حاضر خواهد شد )


    به هرحال امیدوارم با این توضیحاتی که دادم بعضی از دلایل تکنیکی و قانونی اینکه چرا برنامه ایی برای نصب و اجرای Siri رو دستگاه های قدیمیتر الان ممکن نیست رو براتون شفاف کرده باشم. وقتی ما بتونیم کلید رمزگذاری شده روی فایل فیرم ویر آیفون 4S رو بدست بیاریم و جیلبریک آیفون 4S رو داشته باشیم که بتونیم فایلهای مورد نیاز Siri رو بدون داشتن آیفون 4S بیرون بکشیم، خوشبختانه اون موقع ما میتونیم Siri رو روی دستگاه های قدیمی تر هم امتحان کنیم.



    ( و هنوز هم هیچ کس روی آیفون 3Gs و یا آیپاد نسل سوم یا آیپدی که iOS ۵ روش نصب باشه امتحانش نکرده، پس نمیدونیم که کار خواهد کرد یا نه، ولی امیدواریم که کار کنه. )


    منبع :
    ویرایش توسط Arianismmm : 01-11-2011 در ساعت 08:47 PM


اطلاعات موضوع

کاربرانی که در حال مشاهده این موضوع هستند

در حال حاضر 1 کاربر در حال مشاهده این موضوع است. (0 کاربران و 1 مهمان ها)

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •  
اطلاعات سایت
لینک دوستان
درباره سایت
انجمن تخصصی آيفون در سال ۲۰۰۷ با عرضه‌ی اولين نسل گجت‌های iOS اپل فعاليت خود را آغاز نمود. مفتخر هستيم که تا اين لحظه پيشتاز خدمت رسانی به کاربران ايرانی محصولات اپل باشيم.

اکنون ساعت 09:25 AM برپایه ساعت جهانی (GMT - گرینویچ) +4.5 می باشد.

Powered by vBulletin® Version 4.2.3
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.